The Memory League doesn't work anymore


#1

It has been down for days.


(Silvio B.) #2

I have played a game just a few minutes ago. It seems to work fine for me.
Maybe you should write a message on the “contact us”-page.

I think you could also write an email to:
[email protected]


(Josh Cohen) #3

It looks like you have JavaScript turned off, or some kind of browser extension that is blocking some of the JavaScript from loading. Try turning off your browser extensions and/or enabling JavaScript (if it’s turned off).


#4

I don’t have any browser extensions, and I am using JavaScript. I even tried a portable clean installation of Firefox and Chrome. Neither of them worked with Memory League.


(Simon Orton) #5

That’s strange. We haven’t had any other reports of problems.

Does it work in a new incognito window?

If you open the JavaScript console (Command+Option+J on Mac, or Control+Shift+J on Windows), do you see any error messages?


#6

SyntaxError: missing } after function body[Learn More] angular.js:798:27 note: { opened at line 797, column 22angular.js:797:22
TypeError: angular is undefined[Learn More] angular-route.js:58:5
ReferenceError: angular is not defined[Learn More] angularfire.min.js:12:27
ReferenceError: angular is not defined[Learn More] ml201812290913.js:1:14
The resource at “https://www.google-analytics.com/analytics.js” was blocked because content blocking is enabled.[Learn More] app.memoryleague.com
Loading failed for the with source “https://www.google-analytics.com/analytics.js”. app.memoryleague.com:1:1


#7

I tried incognito mode but it doesn’t work either. It also doesn’t work on my Android phone.


#8

It works when I use the Tor Browser.


#9

I just created a virtual machine running Ubuntu and I am still getting the same result. This time I tried a live ISO image. Something is definitely wrong on your end.


(Simon Orton) #10

I wonder if it could be some caching at the ISP level? That has happened to me before, where a certain site wasn’t working for me for a few days on my home network despite it working for everyone else. When you tried it on your Android phone, was that using the same network? Are you able to try it with a different ISP?

Also, what’s the console message in incognito mode? I’m assuming the previous message wasn’t incognito because it mentioned content blocking.


#11

It only works if I use a proxy.

The console message in incognito mode is the same that I posted above.


#12

I figured it had something to do with your CDN. Maybe Cloudflare is banning my IP address.


(Josh Cohen) #13

Does this file load as JavaScript or as a Cloudflare error message? [link removed]

Do you use pi-hole or any kind of network-wide filter?


#14

Yes, that file loads correctly. No, I don’t use any kind of network wide filter.


#15

It also works with my T-mobile data service, but I have to run in incognito mode for it to work. That tells me that the CDN is recognizing the cookies from previous sessions.


(Josh Cohen) #16

@Hypersonic, could you try again and see if it works now?


#17

It works now. What was the problem?


(Simon Orton) #18

That’s great, thanks for letting us know.

It seems like your ISP is stripping out new line characters to save bandwidth, and that broke some of the JavaScript.

Well done @Josh for figuring it out.